Laravel < v8.4.3远程代码执行漏洞预警(CVE-2021-3129)

一、概要

近日,华为云关注到某国外安全团队披露在8.4.3之前的Laravel版本中存在一处远程代码执行漏洞(CVE-2021-3129)。Laravel是一款免费的开源PHP Web框架,在8.4.3之前的版本中,默认的Laravel错误页面生成器Ignition存在漏洞,当Laravel开启Debug模式下运行时,攻击者利用漏洞可触发远程代码执行。目前漏洞利用细节已公开。

华为云提醒使用Laravel的用户及时安排自检并做好安全加固。

参考链接:

https://www.ambionics.io/blog/laravel-debug-rce?spm=a2c4g.11174386.n2.4.7e0d10515RCoXc

二、威胁级别

威胁级别:【严重】

(说明:威胁级别共四级:一般、重要、严重、紧急)

三、漏洞影响范围

影响版本:

Laravel < 8.4.3

facade ignition < 2.5.2

安全版本:

Laravel  >=  8.4.3

facade ignition >= 2.5.2

四、漏洞处置

目前官方已在高版本中修复了该漏洞,请受影响的用户升级至安全版本。

https://github.com/laravel/laravel/releases

https://github.com/facade/ignition/releases

华为云WAF具备对该漏洞防御能力。华为云WAF用户将“Web基础防护”状态设置为“拦截”模式,具体方法请参见配置Web基础防护规则

注:修复漏洞前请将资料备份,并进行充分测试。


智能推荐

联系我们

4000888724

在线咨询:点击这里给我发消息

邮件:service@huawei-cloud.com.cn

地址:请联系各省分公司或代理机构(全国线下合伙人招募中,咨询微信:152285558,电话:19920081119)

QR code